Colorful Addin working with Blend 4 beta

Mar 28, 2010 at 4:15 PM

Greetings,

I was wondering if anyone had got the add-in for Blend to work with Blend 4 Beta. Right now if I download the current version I get a reference error.

Thanks in Advance.

Cheers,

GunnerSr.

Coordinator
Mar 29, 2010 at 9:06 AM

Hi Gunner,

I have not started looking into how to port the add-in to Blend 4 yet. But apparently the integration points for Blend 4 is better than 2 and 3, as you can use MEF to build add-ins. Blend 4.0 will also auto style any panels you add to Blend, which is cool. I found this article with some info on how to do it: http://blog.timmykokke.com/archive/2010/03/21/building-extensions-for-expression-blend-4-using-mef.aspx

Hope to get around to do this as soon as possible.

Cheers,
Jonas

May 4, 2010 at 5:17 PM

Hi Jonas,

I was wondering if there was any progress on this, since this looks like a great extension for Blend..

 

Thanks anyway,

Thomas

Coordinator
May 4, 2010 at 6:26 PM

Hi Thomas,

Well, there is actually some news in regards to Blend 4. Chris Skardon has done an awesome job to update the project to support Blend 4. There is a new alpha-build available at http://colorful.codeplex.com/releases/view/44310 (you can also find it under the download section).

So yes, you can try out the add-in today for Blend 4, and we hope to ship a stable v4.0 release about the same time as Blend 4.

Best regards,
Jonas

Jun 14, 2010 at 5:18 PM

Greetings,

I just tried the beta release of Colorful with the final release of Blend4 and it does not work.  It gives a proxy error (cannot find proxy?).

Is there something that needs to be set other than extracting the dlls to the Extensions folder?

 

Thanks,

Abby

Developer
Jun 14, 2010 at 8:52 PM
Hi Abby, Please right-click on the 'KULER' logo, and select 'Configure Proxy' if you delete the contents (which will probably read 'not-a-proxy') and press OK it should work properly. I will raise a bug and get the defaulted correctly. Sorry! Chris